View Single Post
  #2  
Old 03-03-2010, 06:43 PM
Sherry C's Avatar
Sherry C Sherry C is offline
Product Manager
 
Join Date: Jul 2009
Location: Bad Axe, MI, USA (The Tip of the Thumb of Michigan)
Posts: 2,322
Lightbulb Re: Trouble with GPO

Hi Nima,

To use the GPO Aria player directly with Composer, you'll need a virtual MIDI cable, such as LoopBe (http://www.nerds.de/en/loopbe1.html, download free at http://www.nerds.de/data/setuploopbe1.exe )

Here are the steps you'll need to do. Don't worry - it actually took me a lot longer to type it than it will to do it
1. Download the LoopBe installation file, and install the LoopBe virtual MIDI cable.

2. Run the Aria player, and go to Tools/Preferences.

3. In the "Input MIDI Devices", make sure there is a checkmark beside "LoopBe Internal MIDI(in)"

4. Click "Ok"

5. NOW run Composer. It will automatically detect the LoopBe cable device, which is what connects Composer to GPO Aria.

6. In Composer, click Setup/MIDI Device Configuration (the big one).

7. Right-click the LoopBe Internal MIDI Port (not device yet), and select "Properties"

8. Uncheck the "Open for MIDI input (recording)" box, then click "Ok."

9. Now right-click the LoopBe Internal MIDI Device listing, then click the "Set as default playback device." At this point, you might get a warning box from LoopBe that it has had a feedback loop. That's ok, because all you have to do is to right-click the LoopBe box and uncheck the mute. (this only happens at this one point.)

10. I also strongly urge you at this point, especially if you're going to exclusively use the GPO Aria player, to disable the GS Wavetable. Part of the beauty of the Aria player is that using ASIO drivers, you can get great sounds with no delay in recording or playback. The GS Wavetable interferes with ASIO, though, so you'll want to disable it. To do that, just right-click the GS Wavetable port in MIDI Device Configuration, and uncheck the "Open for MIDI output" box, then click "Ok."
Now, when you use the Aria device for playback, you'll just need to be sure that the channel numbers that are assigned to the loaded instruments there match up with the channel assignments in Composer's Staff/Setup for each of your staves. And be sure to always start GPO Aria BEFORE starting Composer, or it will cause the feedback loop "Mute" issue with LoopBe. If that happens, just uncheck the Mute box in LoopBe, close Aria and Composer, then reopen them in the proper order (that's a LoopBe issue).

Enjoy
Sherry
__________________
Music is to the soul like water is to green growing things.
__________________________________
http://www.beanfieldcastle.net/music.html
Reply With Quote